re = /\{([^}]*):([^}]*)\}/
str = 'I think {if:3|=|0|you are|TechRax is} {range:1|100}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end