#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)M(r|rs|s)\.?\s[A-Z]\w*"
Local $sString = "'2abcdefghijklmnopqrcdtuvxyz'" & @CRLF & _
"'ABCDEFGHIJKLMNOPQRSTUVXYZ'" & @CRLF & _
"'0123456789'" & @CRLF & _
"" & @CRLF & _
"'0988184106', '0911184106'" & @CRLF & _
"" & @CRLF & _
"'0222573153'" & @CRLF & _
"'02 2257 3153'" & @CRLF & _
"2/June/2018" & @CRLF & _
"3:24:23.45" & @CRLF & _
"" & @CRLF & _
"leeyuyi1950@gmail.com" & @CRLF & _
"" & @CRLF & _
"Mr. Schafer" & @CRLF & _
"Mr Smith" & @CRLF & _
"Ms David" & @CRLF & _
"Mrs. Robison" & @CRLF & _
"Mr. T" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"heheh he heh" & @CRLF & _
"" & @CRLF & _
"word /dboundaries odd" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")