re = /M(r|rs|s)\.?\s[A-Z]\w*/m
str = '\'2abcdefghijklmnopqrcdtuvxyz\'
\'ABCDEFGHIJKLMNOPQRSTUVXYZ\'
\'0123456789\'
\'0988184106\', \'0911184106\'
\'0222573153\'
\'02 2257 3153\'
2/June/2018
3:24:23.45
leeyuyi1950@gmail.com
Mr. Schafer
Mr Smith
Ms David
Mrs. Robison
Mr. T
heheh he heh
word /dboundaries odd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end