const regex = new RegExp('M(r|rs|s)\\.?\\s[A-Z]\\w*', 'gm')
const str = `'2abcdefghijklmnopqrcdtuvxyz'
'ABCDEFGHIJKLMNOPQRSTUVXYZ'
'0123456789'
'0988184106', '0911184106'
'0222573153'
'02 2257 3153'
2/June/2018
3:24:23.45
leeyuyi1950@gmail.com
Mr. Schafer
Mr Smith
Ms David
Mrs. Robison
Mr. T
heheh he heh
word /dboundaries odd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}