$re = '/(INSERT INTO) (\S+).*\((.*?)\).*(VALUES).*\((.*?)\)(.*\;?)/m';
$str = 'INSERT INTO TABLE_NAME (COL1,COL2,COL3) VALUES (val1,val2,val3);
INSERT INTO TABLE_NAME(COL1,COL2,COL3) VALUES (val1,val2,val3);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);