re = /(INSERT INTO) (\S+).*\((.*?)\).*(VALUES).*\((.*?)\)(.*\;?)/m
str = 'INSERT INTO TABLE_NAME (COL1,COL2,COL3) VALUES (val1,val2,val3);
INSERT INTO TABLE_NAME(COL1,COL2,COL3) VALUES (val1,val2,val3);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end