// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(INSERT INTO) (\S+).*\((.*?)\).*(VALUES).*\((.*?)\)(.*\;?)").unwrap();
let string = "INSERT INTO TABLE_NAME (COL1,COL2,COL3) VALUES (val1,val2,val3);
INSERT INTO TABLE_NAME(COL1,COL2,COL3) VALUES (val1,val2,val3);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}