import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "remote(?:-(?P<tags>[a-zA-Z0-9+-]+))?-jobs(?:-in-(?P<location>[a-zA-Z0-9+-]+?))?(?:-from-(?<salary>[0-9]+k)-usd)?(?:\\/page\\/(?P<page>[0-9]+))?$";
final String string = "remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2\n\n"
+ "remote-jobs\n\n"
+ "remote-php-jobs\n"
+ "remote-php+laravel-jobs\n\n"
+ "remote-jobs-in-oceania\n"
+ "remote-jobs-in-oceania+worldwide\n"
+ "remote-php-jobs-in-oceania+worldwide\n"
+ "remote-php+laravel-jobs-in-oceania+worldwide\n\n"
+ "remote-jobs-in-oceania-from-20k-usd\n"
+ "remote-jobs-in-oceania+worldwide-from-20k-usd\n"
+ "remote-php-jobs-in-czech-republic+worldwide-from-20k-usd\n"
+ "remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd\n\n"
+ "remote-jobs-in-oceania-from-20k-usd/page/2\n"
+ "remote-jobs-in-oceania+worldwide-from-20k-usd/page/2\n"
+ "remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}