# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"remote(?:-(?P<tags>[a-zA-Z0-9+-]+))?-jobs(?:-in-(?P<location>[a-zA-Z0-9+-]+?))?(?:-from-(?<salary>[0-9]+k)-usd)?(?:\/page\/(?P<page>[0-9]+))?$"
test_str = ("remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2\n\n"
"remote-jobs\n\n"
"remote-php-jobs\n"
"remote-php+laravel-jobs\n\n"
"remote-jobs-in-oceania\n"
"remote-jobs-in-oceania+worldwide\n"
"remote-php-jobs-in-oceania+worldwide\n"
"remote-php+laravel-jobs-in-oceania+worldwide\n\n"
"remote-jobs-in-oceania-from-20k-usd\n"
"remote-jobs-in-oceania+worldwide-from-20k-usd\n"
"remote-php-jobs-in-czech-republic+worldwide-from-20k-usd\n"
"remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd\n\n"
"remote-jobs-in-oceania-from-20k-usd/page/2\n"
"remote-jobs-in-oceania+worldwide-from-20k-usd/page/2\n"
"remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.