re = /remote(?:-(?P<tags>[a-zA-Z0-9+-]+))?-jobs(?:-in-(?P<location>[a-zA-Z0-9+-]+?))?(?:-from-(?<salary>[0-9]+k)-usd)?(?:\/page\/(?P<page>[0-9]+))?$/m
str = 'remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-jobs
remote-php-jobs
remote-php+laravel-jobs
remote-jobs-in-oceania
remote-jobs-in-oceania+worldwide
remote-php-jobs-in-oceania+worldwide
remote-php+laravel-jobs-in-oceania+worldwide
remote-jobs-in-oceania-from-20k-usd
remote-jobs-in-oceania+worldwide-from-20k-usd
remote-php-jobs-in-czech-republic+worldwide-from-20k-usd
remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd
remote-jobs-in-oceania-from-20k-usd/page/2
remote-jobs-in-oceania+worldwide-from-20k-usd/page/2
remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end