const regex = /(?<![0-9.])(0|(?:[1-9]\.[0-9])|10.0)(?![0-9.])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![0-9.])(0|(?:[1-9]\\.[0-9])|10.0)(?![0-9.])', 'g')
const str = `
0
1-9 with one decimal (i.e. 5.5, but not 3.33 or 7)
10.0
All of the following will match: 0, 1.1, 1.0, 1.9, 2.0, 2.1, 9.0, 9.1, 9.9, 10.0, but all of the following will not: 0.1, 0.2, 0.9, 1.11, 1.20, 1.01, 10.05, 110.05.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}