re = /(?<![0-9.])(0|(?:[1-9]\.[0-9])|10.0)(?![0-9.])/
str = '
0
1-9 with one decimal (i.e. 5.5, but not 3.33 or 7)
10.0
All of the following will match: 0, 1.1, 1.0, 1.9, 2.0, 2.1, 9.0, 9.1, 9.9, 10.0, but all of the following will not: 0.1, 0.2, 0.9, 1.11, 1.20, 1.01, 10.05, 110.05.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end