use strict;
my $str = '
0
1-9 with one decimal (i.e. 5.5, but not 3.33 or 7)
10.0
All of the following will match: 0, 1.1, 1.0, 1.9, 2.0, 2.1, 9.0, 9.1, 9.9, 10.0, but all of the following will not: 0.1, 0.2, 0.9, 1.11, 1.20, 1.01, 10.05, 110.05.
';
my $regex = qr/(?<![0-9.])(0|(?:[1-9]\.[0-9])|10.0)(?![0-9.])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}