using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$status\['([^']+)'\][^']*'([^']*)'";
string input = @"$status['Совершенно_новое'] = 'Brand_new<br>New'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}