re = /\$status\['([^']+)'\][^']*'([^']*)'/
str = '$status[\'Совершенно_новое\'] = \'Brand_new<br>New\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end