package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$status\['([^']+)'\][^']*'([^']*)'`)
var str = `$status['Совершенно_новое'] = 'Brand_new<br>New'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}