using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(\w{2}).*\1.*\1.*$";
string input = @"erytypotym5ty
etytyty
koetymitywty
keililmil
ilwrilltyil5ile";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}