re = /^.*(\w{2}).*\1.*\1.*$/m
str = 'erytypotym5ty
etytyty
koetymitywty
keililmil
ilwrilltyil5ile'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end