#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*#.*"
Local $sString = " 1,1,2,3,5,8,13 # numbers to the Fibonnaci sequence" & @CRLF & _
" 1,4,9,16,25,36,49 # numbers of the square number sequence" & @CRLF & _
" 1,1,2,5,14,42,132,429 # numbers in the Catalan number sequence" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")