import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*#.*";
final String string = " 1,1,2,3,5,8,13 # numbers to the Fibonnaci sequence\n"
+ " 1,4,9,16,25,36,49 # numbers of the square number sequence\n"
+ " 1,1,2,5,14,42,132,429 # numbers in the Catalan number sequence\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}