re = /\s*#.*/
str = ' 1,1,2,3,5,8,13 # numbers to the Fibonnaci sequence
1,4,9,16,25,36,49 # numbers of the square number sequence
1,1,2,5,14,42,132,429 # numbers in the Catalan number sequence
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end