import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(import\\s*\\{\\s*)(\\w+)\\s*,([\\w\\s,*]+?)(\\s*\\}(?:\\s*from)?\\s*)([\"'])?([@\\w\\s\\\\/.-]*?)\\5";
final String string = "import { Grid, Heading, Button } from 'component-library'\n"
+ "import { Heading, Button } from 'component-library'\n"
+ "import { Button } from 'component-library'";
final String subst = "$1$2$4$5$6$5\\n$1$3$4$5$6$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}