re = /(import\s*{\s*)(\w+)\s*,([\w\s,*]+?)(\s*}(?:\s*from)?\s*)(["'])?([@\w\s\\\/.-]*?)\5/m
str = 'import { Grid, Heading, Button } from \'component-library\'
import { Heading, Button } from \'component-library\'
import { Button } from \'component-library\''
subst = '$1$2$4$5$6$5\\n$1$3$4$5$6$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result