using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([\w\-+()' .,]+(?:\[[\w\-\/+()' .,]*\][\w\-+()' .,]*)*\.[A-Za-z0-9]{2,4})\b";
string input = @"Subject-KrzpfTest [02/30] - ""KrzpfTest.part.nzb"" yEnc
[PRiVATE]-[WtFnZb]-[Supertje-_S03E11-12_-blabla_+_blabla_WEBDL-480p.mkv]-[4/12] - "" yEnc 9786 (1/1366)
[N3wZ] MAlXD245333\\::[PRiVATE]-[WtFnZb]-[Show.S04E04.720p.AMZN.WEBRip.x264-GalaxyTV.mkv]-[1/2] - "" yEnc 293197257 (1/573)
Singer - A Album (2005) - [04/25] - 02 Sweetest Somebody (I Know).flac
[PRiVATE]-[WtFnZb]-[00000.clpi]-[1/46] - "" yEnc 788 (1/1)
[PRiVATE]-[WtFnZb]-[/More.Bla.S02E01.1080p.WEB.h264-EDITH[eztv.re].mkv] yEnc 2990558544 (1/4173)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}