const regex = new RegExp('\\b([\\w\\-+()\\' .,]+(?:\\[[\\w\\-\\/+()\\' .,]*\\][\\w\\-+()\\' .,]*)*\\.[A-Za-z0-9]{2,4})\\b', 'g')
const str = `Subject-KrzpfTest [02/30] - ""KrzpfTest.part.nzb"" yEnc
[PRiVATE]-[WtFnZb]-[Supertje-_S03E11-12_-blabla_+_blabla_WEBDL-480p.mkv]-[4/12] - "" yEnc 9786 (1/1366)
[N3wZ] MAlXD245333\\\\::[PRiVATE]-[WtFnZb]-[Show.S04E04.720p.AMZN.WEBRip.x264-GalaxyTV.mkv]-[1/2] - "" yEnc 293197257 (1/573)
Singer - A Album (2005) - [04/25] - 02 Sweetest Somebody (I Know).flac
[PRiVATE]-[WtFnZb]-[00000.clpi]-[1/46] - "" yEnc 788 (1/1)
[PRiVATE]-[WtFnZb]-[/More.Bla.S02E01.1080p.WEB.h264-EDITH[eztv.re].mkv] yEnc 2990558544 (1/4173)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}