import re
regex = re.compile(r"\b([\w\-+()' .,]+(?:\[[\w\-\/+()' .,]*\][\w\-+()' .,]*)*\.[A-Za-z0-9]{2,4})\b")
test_str = ("Subject-KrzpfTest [02/30] - \"\"KrzpfTest.part.nzb\"\" yEnc\n"
"[PRiVATE]-[WtFnZb]-[Supertje-_S03E11-12_-blabla_+_blabla_WEBDL-480p.mkv]-[4/12] - \"\" yEnc 9786 (1/1366)\n"
"[N3wZ] MAlXD245333\\\\::[PRiVATE]-[WtFnZb]-[Show.S04E04.720p.AMZN.WEBRip.x264-GalaxyTV.mkv]-[1/2] - \"\" yEnc 293197257 (1/573)\n"
"Singer - A Album (2005) - [04/25] - 02 Sweetest Somebody (I Know).flac\n"
"[PRiVATE]-[WtFnZb]-[00000.clpi]-[1/46] - \"\" yEnc 788 (1/1)\n"
"[PRiVATE]-[WtFnZb]-[/More.Bla.S02E01.1080p.WEB.h264-EDITH[eztv.re].mkv] yEnc 2990558544 (1/4173)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")