using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(.*?)(?<!login)""";
string input = @"This is some a string <a href=""http://www.google.com"">google</a> and this is another that should not be found <a href=""https://www.google.com/login"">login</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}