re = /href="(.*?)(?<!login)"/m
str = 'This is some a string <a href="http://www.google.com">google</a> and this is another that should not be found <a href="https://www.google.com/login">login</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end