$re = '/^[a-zA-Z]+\.[a-zA-Z]\.[a-zA-Z]+\.[a-zA-Z]+@mail.mil|^[a-zA-Z]+\.[a-zA-Z]+@mail.mil$/m';
$str = 'joe.s.smith.ctr@mail.mil
joe.smith@mail.mil';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);