re = /^[a-zA-Z]+\.[a-zA-Z]\.[a-zA-Z]+\.[a-zA-Z]+@mail.mil|^[a-zA-Z]+\.[a-zA-Z]+@mail.mil$/m
str = 'joe.s.smith.ctr@mail.mil
joe.smith@mail.mil'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end