import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bvar\\b([^;^\\{]*?([\\s]*?([<]|[>]|[!]|[=]{2})))([^;]*?)(?!=)";
final String string = "\n"
+ "var->var1 = blah; \n"
+ "var = 8;\n"
+ "if(var >= 9)\n"
+ "if(var ->var1 == balh)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}