re = /\bvar\b([^;^{]*?([\s]*?([<]|[>]|[!]|[=]{2})))([^;]*?)(?!=)/m
str = '
var->var1 = blah;
var = 8;
if(var >= 9)
if(var ->var1 == balh)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end