const regex = /\bvar\b([^;^{]*?([\s]*?([<]|[>]|[!]|[=]{2})))([^;]*?)(?!=)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bvar\\b([^;^{]*?([\\s]*?([<]|[>]|[!]|[=]{2})))([^;]*?)(?!=)', 'gms')
const str = `
var->var1 = blah;
var = 8;
if(var >= 9)
if(var ->var1 == balh)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}