const regex = /(?<=(\d(,\d)?) (g|oz)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(\\d(,\\d)?) (g|oz)?)', 'gm')
const str = `12,2 g this is fully random
89 g random string 2
0,6 oz random stuff
1 really random stuff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}