import re
regex = re.compile(r"(?<=(\d(,\d)?) (g|oz)?)", flags=re.MULTILINE)
test_str = ("12,2 g this is fully random\n"
"89 g random string 2\n"
"0,6 oz random stuff\n"
"1 really random stuff")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")