$re = '/(?<=(\d(,\d)?) (g|oz)?)/m';
$str = '12,2 g this is fully random
89 g random string 2
0,6 oz random stuff
1 really random stuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);