const regex = /(<title><\?php echo L10n::message\('label.edit')(.*?)(<\/title>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<title><\\?php echo L10n::message\\(\'label.edit\')(.*?)(<\\\/title>)', 'gm')
const str = `<title><?php echo L10n::message('label.edit', L10n::label('location')); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('manufacturer', rrue)); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('items.de')); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('water_as')); ?></title>`;
const subst = `<title><?php echo L10n::label('edit'); ?></title>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);