// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<title><\?php echo L10n::message\('label.edit')(.*?)(<\/title>)").unwrap();
let string = "<title><?php echo L10n::message('label.edit', L10n::label('location')); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('manufacturer', rrue)); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('items.de')); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('water_as')); ?></title>";
let substitution = "<title><?php echo L10n::label('edit'); ?></title>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}