using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:ala\s)(?<Ala>\d+))?\s?(?:(?:kota\s)(?<Kota>\d+))?(?:-\d+)?";
string input = @"ala 1-2 kota1
ala 1 kota 1-2
ala 1
ala 1 kota 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}