import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:ala\\s)(?<Ala>\\d+))?\\s?(?:(?:kota\\s)(?<Kota>\\d+))?(?:-\\d+)?";
final String string = "ala 1-2 kota1\n"
+ "ala 1 kota 1-2\n"
+ "ala 1\n"
+ "ala 1 kota 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}