$re = '/(?:(?:ala\s)(?<Ala>\d+))?\s?(?:(?:kota\s)(?<Kota>\d+))?(?:-\d+)?/m';
$str = 'ala 1-2 kota1
ala 1 kota 1-2
ala 1
ala 1 kota 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);