#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\$\d+)(.+?)\$\d+|\$\d+|(?!\$\d+)(.+)"
Local $sString = "foo$12___bar___$34wilma buzz" & @CRLF & _
"hello$ there 12 h___uhuhu$12 otherstuff" & @CRLF & _
"test:$444$44ahahaHA$4$$34" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")