$re = '/(?!\$\d+)(.+?)\$\d+|\$\d+|(?!\$\d+)(.+)/m';
$str = 'foo$12___bar___$34wilma buzz
hello$ there 12 h___uhuhu$12 otherstuff
test:$444$44ahahaHA$4$$34
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);