import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\$\\d+)(.+?)\\$\\d+|\\$\\d+|(?!\\$\\d+)(.+)";
final String string = "foo$12___bar___$34wilma buzz\n"
+ "hello$ there 12 h___uhuhu$12 otherstuff\n"
+ "test:$444$44ahahaHA$4$$34\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}