$re = '/^(?!Accounts)(?:.*\n?){2}/m';
$str = 'Accounts Payable
Company Name
Some Road
Some Town ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);