re = /^(?!Accounts)(?:.*\n?){2}/m
str = 'Accounts Payable
Company Name
Some Road
Some Town '
# Print the match result
str.match(re) do |match|
puts match.to_s
end