use strict;
my $str = 'Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test Equipment
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\History
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\2 - Supply Support Operations
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Operations Logbook
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test.pptx
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\PQDR Response
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\Flightline Support Operations
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\Shipping Track
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\AMS
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\4 - Depot Operating Proc (DOP)
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\1 - Depot Repair Operations
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\0 Transition Lu
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\Cost Analysis
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\5 - Audits
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\6 - Training Requirements
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\DL
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\3 - FSR Support
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test Equipment\\Tool-Equipment Inventory.xlsx
Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test Equipment\\121029-Hand Tools.xlsx';
my $regex = qr/(.*)(\\)(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}