import Foundation
let pattern = #"(.*)(\\)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\TSS Depot Test Equipment
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\History
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\2 - Supply Support Operations
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\TSS Depot Operations Logbook
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\TSS Depot Test.pptx
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\PQDR Response
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\Flightline Support Operations
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\Shipping Track
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\AMS
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\4 - Depot Operating Proc (DOP)
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\1 - Depot Repair Operations
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\0 Transition Lu
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\Cost Analysis
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\5 - Audits
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\6 - Training Requirements
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\DL
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\3 - FSR Support
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\TSS Depot Test Equipment\Tool-Equipment Inventory.xlsx
Z:\sites\TSS-GMS2\TSS\Shared Documents\TSS Depot Operations (Still)\TSS Depot Test Equipment\121029-Hand Tools.xlsx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)