# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(\\)(.*)"
test_str = ("Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test Equipment\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\History\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\2 - Supply Support Operations\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Operations Logbook\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test.pptx\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\PQDR Response\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\Flightline Support Operations\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\Shipping Track\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\AMS\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\4 - Depot Operating Proc (DOP)\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\1 - Depot Repair Operations\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\0 Transition Lu\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\Cost Analysis\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\5 - Audits\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\6 - Training Requirements\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\DL\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\3 - FSR Support\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test Equipment\\Tool-Equipment Inventory.xlsx\n"
"Z:\\sites\\TSS-GMS2\\TSS\\Shared Documents\\TSS Depot Operations (Still)\\TSS Depot Test Equipment\\121029-Hand Tools.xlsx")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.