const regex = /(?<=customer number|cust. nr).*\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=customer number|cust. nr).*\\d+', 'gm')
const str = `bla bla customer number 1234 other text
bla bla again cust. nr. 1234 bla text `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}